Help My Phone (Cell/Mobile)

Discussion in 'Et Cetera, Et Cetera' started by B_ScaredLittleBoy, Aug 30, 2007.

  1. B_ScaredLittleBoy

    B_ScaredLittleBoy New Member

    Joined:
    Feb 24, 2007
    Messages:
    3,337
    Likes Received:
    8
    Hi. My phone has stopped registering calls since 03 Feb which is strange. If I miss a call all I get is a little red symbol in the top of the screen. It doesn't tell me who it was from or the time or anything.

    My phone is a Sony Ericsson W850i ...anyone experienced this/know how to fix it?

    I tried google but all I found were reviews :rolleyes:

    Thanks!
     
  2. B_stanmarsh14

    B_stanmarsh14 New Member

    Joined:
    May 24, 2007
    Messages:
    2,266
    Likes Received:
    6
    Gender:
    Male
    Location:
    Nottingham, England
    Just had a word with a mate from one of the SE forums about this.....

    Before you try the following, you need to know that you WILL loose all settings, & stored numbers. you can back up your phonebook to your sim first, so make sure you do this first before doing any of the following.

    Best off trying a factory reset / master reset from your settings > general menu first (looking at my w300i here, should be the same menu wise generaly on all SE phones), then power off the phone, take out the batt / sim chip / memory card chip, batt back in, power up, get the no sim warning note up, power off again, batt out, sim in, batt in, mem card in & try again.

    Failing that, I am guessing the firmware needs updating, which can be done with your USB cable (DCU - 60).

    Depending if the phone is "network locked", you may need to take it in for a firmware flash, or if it's unlocked, go google for wotan server, & you can do it from there for about €7.
     
  3. B_ScaredLittleBoy

    B_ScaredLittleBoy New Member

    Joined:
    Feb 24, 2007
    Messages:
    3,337
    Likes Received:
    8
    Hmm cool thanks. So the only way is a factory reset? That seems pretty shit. I did read a few other people having this same problem. I'll write all the numbers down then do a reset *sigh*

    Hope it works.
     
Draft saved Draft deleted